A fix has been implemented. Video generation has been restored to normal, and we're monitoring the results.
Posted Mar 19, 2026 - 10:53 UTC
Identified
We're experiencing further delays with video generation. Our Engineering teams have identified the issue, and we're working to restore generation times to normal. We'll provide additional updates as information becomes available.
Posted Mar 19, 2026 - 09:33 UTC
Monitoring
A fix has been implemented, and we are monitoring the results.
Posted Mar 18, 2026 - 23:46 UTC
Identified
Our Engineering Teams have identified the issue, and are working to restore generation times to normal. We'll continue to provide further updates as soon as we have more information.
Posted Mar 18, 2026 - 17:28 UTC
Investigating
We're currently experiencing delays with video generation. Our Engineering teams are investigating the issue, and we'll provide updates as soon as we have more information.