Synthesia Loading Issues

Incident Report for Synthesia

Resolved

This incident has been resolved. Thanks for your patience!
Posted Sep 02, 2026 - 16:22 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted Sep 02, 2026 - 15:23 UTC

Investigating

We are aware of issues affecting platform loading and some may experience delays in the platform. Our engineering team are aware of this and investigating the issues. We will update as soon as we have further information.
Posted Sep 02, 2026 - 14:53 UTC
This incident affected: Editor, Video generation, Video Sharing, and Public API.