Synthesia Loading Issues

Incident Report for Synthesia

Resolved

This incident has been resolved. Thank you for your patience!
Posted Jul 13, 2026 - 16:42 UTC

Monitoring

A fix has been implemented and we are monitoring results.
Posted Jul 13, 2026 - 16:22 UTC

Investigating

We're currently aware of an issue affecting Synthesia loading after login. Our engineering team are investigating now and we will provide updates as soon as we have more information.
Posted Jul 13, 2026 - 15:56 UTC
This incident affected: Editor, Video generation, Video Sharing, and Public API.