Videos failing to display inside the editor

Incident Report for Synthesia

Resolved

Our Engineering Teams have now released a fix, and videos are displaying again inside the editor. However, if any issues persist, please contact our Support Team and we'll be happy to help.
Posted Sep 05, 2025 - 10:59 UTC

Investigating

We're currently experiencing an issue where videos are failing to display while inside the editor. Our Engineering teams are investigating the issue. Our sincere apologies for the inconvenience, and we will continue to provide updates as soon as we have further information.
Posted Sep 05, 2025 - 10:47 UTC
This incident affected: Editor.