Slow loading times for shared Synthesia videos

Incident Report for Synthesia

Resolved

This incident has now been resolved.
Posted Jul 14, 2026 - 18:13 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 14, 2026 - 18:11 UTC

Investigating

We are currently aware of an issue causing slow loading times for shared Synthesia videos. Our engineering team is investigating the matter and we will provide updates as soon as more information becomes available
Posted Jul 14, 2026 - 17:58 UTC
This incident affected: Video Sharing.